Processing of asynchronous jobs is not working as usual

Major incident Web Application EU data center Web Application
2026-05-28 14:33 CEST · 1 hour, 44 minutes

Updates

Resolved

The incident ‘’, which occurred between 2026-05-28 14:33 CEST and 2026-05-28 16:17 CEST, has been resolved.

Our engineering team will review the issue and implement additional measures to prevent similar incidents in the future.

If you continue to experience any problems, please open a ticket with our support team.

We apologize for any inconvenience caused.

May 28, 2026 · 16:17 CEST
Monitoring

Our team has identified the root cause and applied a fix. We will monitor the situation now.

May 28, 2026 · 14:37 CEST
Investigating

Some long-running processes are not working properly:

  • creating payment runs
  • processing of online contracts
  • exporting list
  • downloads & bulk operations

We are investigating this issue currently.

May 28, 2026 · 14:33 CEST

← Back