MySports API has unusually high latency

Major incident EU data center Member Platform
2026-05-12 19:11 CEST · 1 hour, 40 minutes

Updates

Resolved

The incident ‘MySports API has unusually high latency’, which occurred between 2026-05-12 19:11 CEST and 2026-05-12 20:52 CEST, has been resolved.

Our engineering team will review the issue and implement additional measures to prevent similar incidents in the future.

If you continue to experience any problems, please open a ticket with our support team.

We apologize for any inconvenience caused.

May 12, 2026 · 20:52 CEST
Monitoring

The database instance upgrade has completed and the system appears to be recovering. We are now closely monitoring all services to confirm full stability before declaring the incident resolved.

May 12, 2026 · 20:18 CEST
Update

We are still in direct contact with AWS support and their database specialists to complete the ongoing instance upgrade. The process remains in a transitional state and we continue to work on bringing back the database to full operational state.

May 12, 2026 · 20:11 CEST
Update

The database upgrade we initiated to resolve the overload is taking longer than expected. The instance is currently in a transitional state and we are working directly with AWS support to expedite the process.

May 12, 2026 · 19:38 CEST
Update

A database overload on the MySports training backend is causing elevated latency and errors for end users accessing the app. We have identified the root cause and are currently implementing a fix.

May 12, 2026 · 19:17 CEST
Investigating

We’re currently investigating. Users may have trouble using the MySports App and/or Web application.

May 12, 2026 · 19:11 CEST

← Back