Dutch users of MySports App (v3.87) experience functionality issues

Minor incident EU data center Member Platform
2026-03-24 12:00 CET · 4 hours, 28 minutes

Updates

Post-mortem

Incident Summary: Following a recent system update, an issue was identified where certain regional settings were not correctly recognized. This prevented the application from accurately processing localized time information for users in specific locations.

Impact on Users: The issue affected members in the Netherlands, Luxembourg, and select individual studios. Users in these regions experienced errors when accessing time-sensitive features within the app.

Our Response: Once alerted to the issue by our support team, our engineers identified the cause and implemented a fix to restore full functionality. We have since updated our internal systems to ensure all regional settings are correctly supported moving forward.

Future Prevention

  • Comprehensive Coverage: We have transitioned to a more robust regional settings database to ensure all locations remain supported during future updates.
  • Enhanced Testing: New automated tests have been added to our development process to verify common regional settings before any update is released.
  • Proactive Monitoring: We are improving our internal alerting systems to detect regional errors automatically, allowing us to respond more quickly in the future.

Current Status The incident is resolved and all services are operating as expected across all regions.

April 7, 2026 · 16:31 CEST
Resolved

The incident , which occurred between 2026-03-24 11:00 CET/CEST and 2026-03-24 14:31 CET/CEST, has been resolved.

Our engineering team will review the issue and implement additional measures to prevent similar incidents in the future.

If you continue to experience any problems, please open a ticket with our support team.

We apologize for any inconvenience caused.

March 24, 2026 · 16:28 CET
Monitoring

The fix has been successfully rolled out to the affected production services. Validation tests confirm that the issue has been for resolved as expected. We will continue to closely monitor the system to ensure ongoing stability.

March 24, 2026 · 15:31 CET
Update

The fix has been implemented and is now being rolled out to the affected production services. We are continuing to monitor the situation closely to ensure the effectiveness of the resolution.

March 24, 2026 · 15:01 CET
Update

The implementation of the fix still ongoing. We’ll continue providing updates until we’ve confirmed the fix is live and functional.

March 24, 2026 · 14:12 CET
Update

The implementation of the fix is ongoing. We’ll continue providing updates until we’ve confirmed the fix is live and functional.

March 24, 2026 · 13:38 CET
Update

We identified the root cause of the issue and are working on a fix currently.

March 24, 2026 · 13:02 CET
Update

We identified the root cause of the issue and are working on a fix currently.

March 24, 2026 · 12:37 CET
Investigating

An issue has been identified in the MySports app (v3.87) specifically affecting studios and users in the Europe/Amsterdam region. This disruption prevents core features, such as studio QR codes for check-in and course bookings, from loading correctly. Our team has identified the root cause and is working on a fix to restore full functionality for all affected locations. We apologize for the inconvenience.

March 24, 2026 · 12:00 CET

← Back