Partial Outage across multiple systems

Minor incident Web Application EU data center
2026-03-07 18:35 CET · 6 minutes

Updates

Resolved

The incident Partial Outage across multiple systems, which occurred between 2026-03-07 17:35 CET/CEST and 2026-03-07 17:42 CET/CEST, has been resolved.

Our engineering team will review the issue and implement additional measures to prevent similar incidents in the future.

If you continue to experience any problems, please open a ticket with our support team.

We apologize for any inconvenience caused.

March 7, 2026 · 18:42 CET
Investigating

We are currently experiencing performance degradation and intermittent availability across several systems. Some features may be slow or unavailable. Our team is investigating the root cause.

March 7, 2026 · 18:35 CET

← Back