Outgoing Email Delivery Currently Unavailable

Minor incident Web Application EU data center
2025-11-28 22:03 CET · 54 minutes

Updates

Resolved

All pending emails have now been successfully delivered. The issue is fully resolved, and normal email delivery operations have been restored.

November 28, 2025 · 22:57 CET
Monitoring

Email delivery has been restored, and outgoing emails are now being successfully sent again. We are currently processing and delivering all pending emails. We will continue to monitor the system to ensure everything remains stable.

November 28, 2025 · 22:29 CET
Update

We have confirmed that outgoing emails are currently undelivered. Our team is in active contact with our email provider, and we are working together to implement a fix. Once the solution is in place, we will process and deliver all pending emails. We will share further updates as soon as they become available.

November 28, 2025 · 22:14 CET
Investigating

We are currently experiencing an issue that is preventing outgoing emails from being delivered. Our team has identified the problem and is actively implementing a fix. Further updates will be provided as we make progress. Thank you for your patience.

November 28, 2025 · 22:03 CET

← Back