Partial Display Errors in Cash Register Product Overview

Minor incident Web Application EU data center Web Application
2025-10-15 18:18 CEST · 1 hour, 37 minutes

Updates

Resolved

The incident has been resolved!

October 15, 2025 · 19:55 CEST
Investigating

We’ve identified an issue affecting the product overview in the cash register. A fix is being implemented and will be deployed shortly.

October 15, 2025 · 18:18 CEST

← Back