We're currently encountering problems with the check-in

Major incident EU data center Access Control System
2025-08-07 16:56 CEST · 1 hour, 21 minutes

Updates

Resolved

The incident has been resolved.

August 7, 2025 · 16:56 CEST
Monitoring

A fix has been deployed and we are monitoring the results.

August 7, 2025 · 16:56 CEST
Investigating

We’re currently experiencing problems with the check-in process. The issue has been identified. A fix will be deployed in a few minutes

August 7, 2025 · 16:56 CEST

← Back